iCloud Photo Library problem

How to Fix iCloud Photo Library Problems

I’ve been having problems with my iCloud Photo Library this week, so I am deciding to write a blog post about it. I haven’t been able to find anything written anywhere online about this particular issue, but surely there are other people out there having the same problem as me since updating to iOS 9.3. The good news is that I think I figured out how to resolve it. Hopefully, this post will find others having the same problems and will help them too.

Here are a few of the things that alerted me to something being wrong:

  1. I could not save any edits to my photos in the Photos app. Whenever I would try, it would tell me “There was an error saving this photo. Please try again later.” Later never arrived.

  2. I could not add photos to a shared photo stream. I should possibly state that I could not do this “reliably.” My usual method of sharing is to view the photo in the Photos app, tap the share sheet, then tap the iCloud Photo Sharing button. After specifying which photo stream to post to, it would always go without any issues. However, now I could perform all those steps without alerts, but the photo would not show up in the photo stream. I did manage to add one or two photos to a photo stream by going into the shared photo stream itself, and tapping on the big + button at the bottom, and selecting a photo to add. However, after I did it once and thought this might help me, I wasn’t able to repeat it again.

  3. It seemed that I was always having to wait for every photo to download from iCloud. I have seen this on my iPad and am accustomed to it there. However, this was happening on my iPhone 6S. I shoot 99% of my photos with that device, and despite having the photo storage set to Optimize, I rarely have to download shots, and especially recent ones. You know that the photo is not stored on your device when it initially loads a rather blurry version of the pic, and then a few seconds later it just snaps into high resolution focus. I was experiencing this for pictures that I shot only days ago. For something from a few years back, that’s understandable. But I’ve never experienced this for something so recent. Furthermore, once I had downloaded the high resolution version, I noticed that I now had to do this almost every time I wanted to view the photo. This was definitely something new.

Importantly, I had confidence that my photos were safely stored in iCloud, because even though I was having these issues, new photos taken with my iPhone were uploading and syncing to my Mac running the latest version of El Capitan, 10.11.4. In addition to that, my Mac is backing up through Time Machine to multiple drives. So, this is another example of BACK UP YOUR DATA! I’d never want to troubleshoot and experiment with something as important as photos without having a backup to fall back on if needed.

I tried to figure out if I had done anything to my devices lately to prompt such strange behaviour. I don’t typically download a lot of apps, and I hadn’t for a while, so it wasn’t that. I don’t usually change up my workflows and routines, so there likely wasn’t something I changed to have triggered this. But oh wait… coincidentally enough, I did download iOS 9.3 earlier this week. I can’t confirm that was the cause of my problem, but it sure seems like it must be connected.

I tried the obvious things first. I killed the app and then reopened it. That didn’t help. I restarted my phone. That didn’t help. I shut down my phone completely before powering it back on. That didn’t help.

I thought to try connecting with @AppleSupport on Twitter, since I’ve heard remarkably positive reviews of their service. They responded within a few hours, and we had a pretty good conversation through direct messages. I explained the problem and they offered me a few things to try. Their suggestions didn’t work directly, but they did lead me to my own solution. (They possibly may have given me the solution eventually, but with a few hours in between direct messages, I got impatient and started experimenting!)

The first thing they suggested for me to do was to disable and then reenable iCloud Photo Library. I was hesitant to do this, because it’s a bit daunting to consider completely removing your photo library, and then hoping it comes back again later. These are precious memories, not just documents or something far less personal and important. But as I said, I had confidence because I knew it was all safe and sound on iCloud, and then synced to my Mac, and then backed up multiple times from there.

So, disable and reenable iCloud Photo Library. No problem. And… that didn’t help. When I looked in the Photos app, in the Years view, I could see a bunch of gray thumbnails and sporadic image thumbnails. But the thumbnails were not all coming back. I watched a few fill in, but soon after, the network activity spinner in the top bar disappeared and the downloads stopped coming in altogether. And, I still couldn’t save edits or share photos.

Very frustrating…

I tried to disable iCloud Photo Library in combination with a phone restart. I think this was now getting somewhere. As soon as I disabled it, I went to the Photos app, and from the Years view, I watched the lines of photo thumbnails disappear until the app told me I had no photos saved. Then I restarted the phone, and once back on, I reenabled the library. This time, I watched as gray thumbnails appeared line by line to make up the years of photos stored in iCloud. So, I definitely knew that the app knew about my photos, because seconds earlier, I was completely cut off from them. Now, though, they were still just gray boxes, and the actual photo thumbnail wasn’t downloading as I’d expect.

However, I noticed that when I zoomed in a few levels to the Moments view, all of the gray boxed had a small cloud icon on them, and seconds later, the boxes on the screen were populated with the actual image thumbs. Tapping on the image launched me into the full size photo, and after a second of downloading, I had the full resolution image again. Back to the Moments view, I noticed that if I would scroll through my list, the gray thumbnails would populate with image thumbnails almost as fast as I could scroll. So that’s what I did.

I scrolled through my list in the Moments view, starting with today, and flinging backwards through several years worth of photos. Periodically I would stop and go back to make sure it was keeping up with filling in the blanks, and sometime I noticed that I was scrolling too quickly for it to do so. But as long as I was continuously scrolling at a “not too fast but still pretty fast” rate, I was good. After a few minutes of this, I had repopulated all of the gray boxes with the actual photo thumbnails.

I don’t know enough about how iOS or iCloud Photo Library or the Photos app work to elaborate on this at all, but somehow, once I had fixed the thumbnail problem, I was able to save any edits I made on the photos, and I was also able to share on my photo stream again.

I have to note that this resolution clearly only applied to the device that I was working with, or my iPhone 6S in this case. When I checked to see if it had done anything to the online photo library itself to cause this to be resolved, I found that my iPad still gave me the same problems. So, I have to now repeat the process with my iPad later. Hopefully I will have the same resolution, and I’ll update this post with the results of that.

As I mentioned, I am writing this because I struggled to find a solution online to these precise symptoms. However, if this is truly connected to my iOS 9.3 update, then I have to believe that there are others out there going through the same frustrations. Hopefully they will find this post, and hopefully it will help them to fix one of their most loved and important apps.